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Canvastic has a versatile interface, allowing access for users. The
interfaces can be customized for the age or ability of the user. There are
several interfaces that range from beginner to advanced users. The primary
sets have only a few necessary tools and limited options. The more
advanced interfaces have all the tools and all the options enabled. This
flexibility is a signature feature for Canvastic.
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Preferences and Preference Sets

Preference sets are key to making Canvastic work for students. You can customize the
Tools, Colors, Choices, Preview, Document and Browser palettes, document size
and placement, and spell checking function. The preference sets can be adjusted as
the users become comfortable with the tools and options. Canvastic ships with a
collection of preference sets that are stored in the Preferences Library, but you can
create your own and customize your work environment as you'd like.

Note: By default Canvastic will start up using the default preferences that are at a
3rd to 4th grade level.

For more Information on setting preference for students visit the Canvastic website
www.canvastics.com

The Other Tab: These controls effect how the palettes and preferences work.

o Palettes can be locked to prevent accidental movement and tool hiding by
younger users. Recommended for elementary students.

e The color swatches can be locked to prevent accidental access to the system's
color picker with a double click. Recommended for primary elementary students.

e The Contextual menu can be disabled preventing Control click and right click
access to menu commands. Recommended for primary elementary students.

e The 3 color choice columns in the Colors palette can be linked for younger users.
Line and Fill can be linked leaving Text separate. All 3 can be linked for very
young students.

e Canvastic will launch with a default preference set until you uncheck the “Use
only default preferences” checkbox to allow students to select from a list of
preferences at startup. You'll find more details about that below.

e You can designate an alternate folder as the preferences folder, including a
shared location on a network. This allows the sets to be adjusted in one place but
provides those adjustments to everyone on the network immediately.

The Canvastic preference selection window

K is the simplest and the advanced choices are the most complex and capable. When
you launch Canvastic you will see them. You should choose one and click the Open
button. During a session in Canvastic, you can change preference sets. To do so, open
the Preferences window and press the Open. You will be able to adjust setting from
these screens.

Palette Windows

The palette windows contain the tools and options that bring Canvastic to life. Each is
described below. You can show and hide individual palette windows by selecting the
appropriate menu items in the Window menu. The size and position of palette windows
can be locked by checking the Lock Palettes checkbox in the Preferences window.
When the palette windows are not locked, you may move them by clicking and dragging
their window title.



Lock/Unlock: You can un-lock the palettes for quick changes by using a special key
combination and clicking in a blank area of any palette. Blank areas are those without
buttons but not on the title bar. Anywhere in the Preview palette will work. On
Macintosh, hold down the Control and Option keys while clicking. On Windows hold
down the Ctrl and Alt keys while clicking. This feature allows teachers to customize the
environment quickly for individual students as needed.

Tools Palette
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The Tools palette contains icons for all of the available paint and object tools in
Canvastic. All of the paint tools appear in the top row of the palette next to the paint tool
indicator"s_. All of the object tools appear in the bottom row of the palette next to the

object tool indicator s, . Click a tool icon to select it. Once selected, click (or click and

drag) in the canvas to use the tool. The function of each tool is described on the Paint
tools page and the Object tools page in this documentation.

When the palettes are unlocked (see preferences), you may remove a tool icon from the
palette window by using the commands for hiding tools in the side menu [ .. You may
restore a tool icon to the palette window by using the commands for showing tools in the
side menu| 4.

When the palettes are unlocked, you may resize the Tools palette by choosing Tool
Size... from the side menu[ .. You may want to enlarge the icons to make it easier for
younger users to click them.
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The Colors palette contains columns of standard color choices for line =, fill =, and
text Tt.



Click a color to select it for use. Double-click a color to change it, using the operating
system's standard color picker. Add more colors to the palette by using the side menu
| +Jand choosing Add Color...

When the palettes are unlocked (see preferences), you may resize the Colors palette by
choosing Swatch Size... from the side menu[ .. You may want to enlarge the colors to
make it easier for younger users to click them.

Transparency

You can adjust the tone and transparency of the colors selected by dragging the small
sliders at the bottom of the palette. The top of the slider is totally saturated solid color
and the bottom is almost completely transparent with just a hint of the selected color
showing. There is a slider for the line, fill and text color choices.

This image shows the same text box object at full color, half transparency, and full
transparency.

Some aspects of the Colors palette can be controlled in the preferences:

e You can disable the color picker usually accessed by double clicking.

e You can link all 3 color choices for very young students who don't use the text or
word processing tools.

e You can link the line and fill colors for very young students who use the text or
word processing tools.

e Note: You can un-lock the colors for guick changes by using a special key
combination. On Macintosh, hold down the Control and Option keys while
double-clicking. On Windows hold down the Ctrl and Alt keys while double-
clicking. This allows you to enter the system’s color picker even if the
Colors palette is locked.

Choices Palette

Choices
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The Choices palette allows you to modify the settings for individual tools as you are
using them. Drag the Line slider to grow or shrink the line width for the selected object
or shape about to be drawn. You may also click on the line to change this setting.




Clip Art

When a Clip Art tool is selected, the Choices palette displays thumbnail pictures of the
available clip art that may be added to the canvas.
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As its name implies, the Preview palette displays a preview of what is about to be added
to the canvas. It reflects the current selections in the Tools, Colors, and Choices
palettes.

Browser Palette

Browser

The Browser palette shows small thumbnail images of your open documents. Click on a
thumbnail to bring that document to the front. It is a great tool for young users to switch
between documents without having to learn to navigate through the Window menu.

Document Palette

Document

- 5
JEET e

The Document palette holds the four shortcut buttons for often-used commands that
deal with Canvastic Documents. You can adjust the sizes of the tools by using the side
menu button. |

<)
e New Document tool creates a new, blank document on screen.
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e Open tool displays the open dialog box so you can find and open a
previously saved document.
%
e Save tool displays the save dialog box so you can name and save your
document.

e Print tool é prints your document.

Paint Tools

The Paint tools are used to color individual pixels or dots on the screen. They are
sometimes called bitmapped graphics. For example, when you paint a red stroke across
a green area the red replaces the green. Painted graphics can be erased bit-by-bit with
the Eraser tool. These are the tools used when actually creating a hand drawn picture of
a house or animal or scene. Most primary students will use only the bitmapped or paint
tools. The paint tools are normally used when drawing pictures. The Paint tools only
affect the Paint layer (see the Layers section).

Default settings for color, transparency, line thickness etc. can be set and saved for all
of Canvastic's tools. See the Preferences section for instructions.

The Paint Tools section of the Tools palette
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Tool Descriptions

f Brush

The Brush tool is the main picture making tool in Canvastic. It is used as a pencil, paint
brush, crayon, or marker would be used on paper. With the Brush tool selected, click
and drag in the canvas to paint. Release the mouse button to stop painting. Slow,
careful mouse movements make it easier to control the brush.

Adjust the width of the brush stroke by moving the Line slider in the Choices palette. Set
the brush stroke color and transparency by selecting the appropriate line color in the
Colors palette.

Four brush shapes are available. Click the brush shape next to the line size in the
Choices palette to cycle through the choices.



Choices
. ’ Arial Black 3
" I

/
N\ ”

= Eraser
The Eraser tool erases paint from the paint layer. It works like the paint brush tool
except it removes color on the paint layer to reveal the background color or picture
(usually white). Adjust the width of the eraser stroke by moving the Line slider in the
Choices palette. Note: The eraser will only erase marks made by the other paint
tools. It will not erase objects made with object tools or pixels on the background

layer.

&Fill

The Fill tool is used for coloring in areas of your work quickly and completely. You could
use the Brush tool to color as you would with a crayon or marker on paper, but the Fill
tool is faster and more accurate. With the Fill tool selected, click in the canvas with the
tip of the pouring paint in the area to be colored. All of the adjoining like-colored pixels
next to the one you clicked will be filled with the same color. So if you click it on a blank
canvas the whole canvas will be painted the chosen color. If you click it inside a closed
shape like a rectangle the area inside the shape will be colored.

In the first example the orange fill color has completely covered the inside of the yellow
drawing. In the second example the orange fill color has "leaked" out the small hold in
the yellow drawing.




] Rectangle

Use the Rectangle tool to create perfect rectangles and squares. With the Rectangle
tool selected, click and drag in the canvas to create a rectangle. Drag in a diagonal
direction. Press and hold the Shift key while you drag to create a perfect square.

Adjust the width of the shape outline by moving the Line slider in the Choices palette.
Set the color of the rectangle outline and fill (inside) by selecting the appropriate line, fill
color and color transparency respectively in the Colors palette.

D Square .

Use the Square tool to create perfect squares. With the Square tool selected, click and
drag in the canvas to create a square. Drag in a diagonal direction.

Adjust the width of the shape outline by moving the Line slider in the Choices palette.
Set the color of the square outline and fill (inside) by selecting the appropriate line, fill
color and color transparency respectively in the Colors palette.

O Ellipse

Use the Ellipse tool to create perfect ovals and circles. With the Ellipse tool selected,
click and drag in the canvas to create an ellipse. Drag in a diagonal direction. Press and
hold the Shift key while you drag to create a circle rather than an ellipse.

O Circle .

Use the Circle tool to create circles. With the Circle tool selected, click and drag in the
canvas to create a circle. Drag in a diagonal direction.

/ Line
Use the Line tool to create straight lines. With the Line tool selected, click and drag in

the canvas to create a line. Press and hold the Shift key while you drag to force the line
to a horizontal or vertical orientation.

"-f Connect-The-Dots

Use the Connect-The-Dots tool to create a shape comprised of one or more connected
straight lines. With the Connect-The-Dots tool selected, click in the canvas to set the
starting point. Move your mouse to the position of the next end point and click to set it.
Repeat as many times as necessary. When you are ready to complete the shape,



double-click the final point. Press and hold the Shift key while you move the mouse to
force the current line to a horizontal or vertical orientation.

Adjust the width of the lines by moving the Line slider in the Choices palette. Set the
color of the lines by selecting the appropriate line and color transparency in the Colors
palette.

Four brush shapes are available. Click the brush shape next to the line size in the
Choices palette to cycle through the choices.

A A
Triangle

Use the Triangle tool to create triangles. With the Triangle tool selected, click and drag
in the canvas to create a triangle. Drag in a diagonal direction. Press and hold the Shift
key while you drag to orient the triangle in 90 degree increments.

Adjust the width of the shape outline by moving the Line slider in the Choices palette.
Set the color of the triangle outline and fill (inside) by selecting the appropriate line, fill
color and color transparency respectively in the Colors palette.

Clip Art

Use the Clip Art tool to add pictures to your document. With the Clip Art tool selected,
click in the canvas to place a new picture. You can adjust the transparency of the clip
art using the Colors Palette fill transparency control slider.

Categories: When you select the Clip Art tool, the Choices palette window display will
change to show the categories of clip art. Clicking the disclosure triangle for a folder will
show the thumbnail previews of the available clip art. The selected thumbnail will be
displayed in the Preview palette. Chaices Preview )
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Canvastic comes with Arrows, Basic Clip Art, Basic Clip Art-mini (great for counting and
sorting activities), Bubble Shapes (for comic book style dialog), Drawing Aids (pale gray
hints of images to finish drawing), Math, and Speckles (allow you to give a hint of color

without wasting expensive ink). You can extend Canvastic's clip art selection by adding
your own graphics files to the Art folder in the Canvastic application folder. You can add
jpeg, gif, png, tiff, pict, and bmp files to that folder.

Note: Add new clip art to an existing folder or create a new folder.
Note: Pure white in clip art is seen by Canvastic as transparent.




Tt Text

Use the Text tool to add text that cannot be edited to your document. The text created
by this tool just becomes painted graphics on your canvas, which cannot be changed.
To add editable text, use the object Text tool or the object Word Processing tool. This
tool is usually only used for creating a very large letter or number on the canvas not for
real text entry.

Aa See the Spell Check section for more information on that feature.

While it is still selected, you may position the new text box. Selecting a different tool will
fix the text box in its current position at the time.

All choices about font, size, style, transparency and colors must be made before you
enter text with this tool since after typing your work becomes just painted graphics on
the canvas.

Note: Do not use this tool for creating text that you want to edit later! Use the
object Text or Word Processing tool.

t--4 Selection Rectangle

Use the Selection Rectangle tool to select or choose areas of your painting. With the
Selection Rectangle tool selected, click and drag in the canvas. Drag in a diagonal
direction. Press and hold the Shift key while you drag to create a selection square rather
than a selection rectangle.

The area selected is shown by a magenta rectangle.

To deselect an area, click (but do not drag) outside the current selection or choose a
different tool from the Tools palette.

Note: The Selection Rectangle tool will only select marks made by the other paint
tools. It will not select objects made with object tools or pixels on the background

layer.

After creating it, you can do several things with a new selection:

e You can erase the contents by pressing the Delete or Backspace key.

e You can move the contents by clicking, holding, and dragging from within the
rectangle. Drag until the contents are in the correct spot and then release the
mouse button. Press and hold the Shift key while you drag to move the selection
in a purely horizontal or vertical direction.
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e You can move the selection up, down, left or right 1 pixel by pressing the arrow
keys on your keyboard. Press and hold the Shift key while you press the arrow
keys to move the selection 10 pixels at a time.

e You can make copies of the selection three ways:

1. Press and hold the Option (Macintosh) or Alt (Windows) key and click,
hold, and drag. Drag until the contents are in the correct spot and then
release the mouse button.

2. Select Copy and then Paste from the Edit menu. The newly pasted
selection will be selected so you can drag it to the correct location.

3. Select Duplicate from the Edit menu. The newly created selection will be
selected so you can drag it to the correct location.

- :
Selection Lasso

Use the Selection Lasso tool to select an irregularly shaped area of your painting. Click
and hold down the mouse button while moving the mouse. Release the button to stop
selecting. The area being selected is shown with a magenta line as you drag the
mouse.

To deselect an area, click outside the current selection or choose a different tool from
the Tools palette.

Note: The Selection Lasso tool will only select marks made by the other paint
tools. It will not select objects made with object tools or pixels on the background layer.

After creating it, you can do several things with a new selection:

e You can erase the contents by pressing the Delete or Backspace key.

e You can move the contents by clicking, holding, and dragging from within the
rectangle. Drag until the contents are in the correct spot and then release the
mouse button. Press and hold the Shift key while you drag to move the selection
in a purely horizontal or vertical direction.

e You can move the selection up, down, left or right 1 pixel by pressing the arrow
keys on your keyboard. Press and hold the Shift key while you press the arrow
keys to move the selection 10 pixels at a time.

e Select Copy and then Paste from the Edit menu. The newly pasted selection will
be selected so you can drag it to the correct location.
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Re-sizing a Selection

You can change the size of a paint selection by following these directions. These same
directions can be used to move any painted graphics to the object layer or objects to the
painted layer.

Selection the area you want to change with the Selection Rectangle or Lasso.
Choose Cut from the Edit Menu.

Select one of the Object tools.

Choose Paste from the Edit Menu. The graphic will be pasted in as an object
since an object tool was selected.

Click hold and drag one of the magenta handles until the size and shape is
changed.

Choose Cut from the Edit Menu.

Select one of the Paint tools.

Choose Paste from the Edit Menu. The graphic will be pasted in as paint since a
paint tool was selected.
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Eyedropper V3
Use the Eyedropper tool to capture colors from the Canvastic canvas that you may want
to use. Click on the color with the tip of the eyedropper to "sample” the underlying color.
If it does not already exist in the Colors Palette, it will be added at the bottom. Choose
your graphics tool and then pick the new color to paint it on the canvas.

This illustration shows the Eyedropper tool being used on a photo and the new color
that was added to the Colors Palette.

Note: The Macintosh color picker will allow you to “get” colors from anywhere on
the screen. See the Colors Palette section for more information on adding and
adjusting colors.

Object Tools

The Object tools are used to create shapes and lines that exist as separate objects,
which do not erase what is underneath. In fact, they each exist on their own invisible
layers "above" the painted pictures (see the Layers section). Because they exist as
separate objects, they can be moved around and positioned independently or in groups
making it possible to layout a page for printing in an exact way. Object graphics can be
deleted but not erased. Object graphics can easily have different choices applied to
them such as color, thickness, and size because they are not painted on the screen.
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The Object Tools section of the Tools palette
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NOTE: The rectanqgle, square, ellipse, circle, line, connect the dots, triangle, and

clipart tools work the same as the paint tools, however they are created on their

own individual layer.

Tool Descriptions

3
[} Pointer

Use the Pointer tool to select, move, and resize objects you've created on the draw
layer. With the Pointer tool selected, click an object to select it. Small square magenta
selection handles will appear at each corner to show that the shape is selected. You

can have more than one object selected at a time. You may select one or more objects
by clicking and dragging a selection rectangle that completely encloses all of the shapes

you want to select. You may also Shift-click individual objects to add them to the
selection one at a time.

To deselect an object, click (but do not drag) outside the selected object, Shift-click the

already selected shape, or choose a different tool from the Tools palette.

Note: The Pointer tool will only select objects made by the other object tools. It

will not select marks made with paint tools or pixels on the background layer.

You must select an object before it may be modified. Once selected, you may:

o Delete the selected objects by pressing the Delete or Backspace key.

e Move the selected objects by clicking, holding, and dragging to a new location in
the canvas. Press and hold the Shift key while you drag to move the objects in a

purely horizontal or vertical direction.

« Move the objects up, down, left or right 1 pixel by pressing the arrow keys on
your keyboard. Press and hold the Shift key while you press the arrow keys to

move them 10 pixels at a time.

« Resize a selected object by clicking and dragging one of its magenta selection

handles.

e Double-click an object text box to reopen the text entry window and change the

text in the box.

e Select colors in the Colors palette and options in the Choices palette to change

the selected objects.
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Text

Use the Text tool to add short editable text boxes to your document. Use the Word
Processing tool to add longer text passages with mixed formatting. With the Text tool
selected, click in the canvas to set the upper-left point of a new text box. Click and drag
to define the bounds of a new text box rectangle. When you release the mouse button,
a text entry window will appear.

Text
Text entry dialog box...

( Cancel ) 0K

# Freehand

Use the Freehand tool to add free-form lines and shapes to your document. It is used as
a pencil; paint brush, crayon, or marker would be used on paper. With the Freehand tool
selected, click and drag in the canvas to draw. Release the mouse button to stop
drawing.

Adjust the width of the line by moving the Line slider in the Choices palette. Set the line
color and transparency by selecting the appropriate line color in the Colors palette.

This Freehand tool line is selected and is showing the magenta
"handles". n

Press and hold the Shift key while you drag to move the objects in a purely horizontal or
vertical direction.

e

"“Word Processing

Use the Word Processing tool to add editable text to your document that can be
formatted with more control than the Text tool. Use the Text tool for short labels or titles
that will be uniformly formatted. Use the Word Processing tool for sentences,
paragraphs, and longer passages with mixed formatting. With the Word Processing tool
selected, click in the canvas to set the upper-left point of a new word processing object.
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Click and drag to define the bounds of a new word processing object rectangle. When
you release the mouse button, a word processing entry window will appear.

Word Processing
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Enter text here...

Word Processing entry dialog with Spell Check enabled. See the Spell Check section
for more information on this feature.
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